summaryrefslogtreecommitdiff
path: root/Com/Simatime/web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Com/Simatime/web.nix')
-rw-r--r--Com/Simatime/web.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/Com/Simatime/web.nix b/Com/Simatime/web.nix
new file mode 100644
index 0000000..d6be348
--- /dev/null
+++ b/Com/Simatime/web.nix
@@ -0,0 +1,41 @@
+{ ... }:
+
+let
+ bensIp = "69.181.254.154"; # hikuj-zupip
+in
+{
+ services = {
+ nginx = {
+ enable = true;
+ recommendedGzipSettings = true;
+ recommendedOptimisation = true;
+ recommendedProxySettings = true;
+ recommendedTlsSettings = true;
+ virtualHosts = {
+ "bsima.me".root = "/home/ben/public_html/";
+ "www.bsima.me".root = "/home/ben/public_html/";
+ "simatime.com".locations."/".root = "/srv/www/";
+ "firefoxsync.simatime.com".locations."/".proxyPass = "http://localhost:5001";
+ "hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
+ "tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
+ "deluge.simatime.com".locations."/".proxyPass = "http://${bensIp}:8112";
+
+ "notebook.simatime.com".locations = {
+ "/" = {
+ proxyPass = "http://${bensIp}:3099";
+ proxyWebsockets = true;
+ extraConfig = ''
+ proxy_buffering off;
+ proxy_read_timeout 86400;
+
+ '';
+ };
+ "/(api/kernels/[^/]+/channels|terminals/websocket)/" = {
+ proxyPass = "http://${bensIp}:3099";
+ proxyWebsockets = true;
+ };
+ };
+ };
+ };
+ };
+}