summaryrefslogtreecommitdiff
path: root/Hero/Service.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Hero/Service.nix')
-rw-r--r--Hero/Service.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/Hero/Service.nix b/Hero/Service.nix
index f0f4227..8bad6d7 100644
--- a/Hero/Service.nix
+++ b/Hero/Service.nix
@@ -18,6 +18,11 @@ in
The port on which herocomics-server will listen for incoming HTTP traffic.
'';
};
+ dataDir = lib.mkOption {
+ type = lib.types.path;
+ default = "/var/lib/hero";
+ description = "herocomics-server database directory";
+ };
server = lib.mkOption {
type = lib.types.package;
description = "herocomics-server package to use";
@@ -50,6 +55,7 @@ in
Environment = [
"HERO_CLIENT=${cfg.client}/static"
"HERO_PORT=${toString cfg.port}"
+ "HERO_DATA_DIR=${cfg.dataDir}"
];
Type = "simple";
Restart = "on-abort";