summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/nostr-rs-relay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/nostr-rs-relay.nix')
-rw-r--r--Omni/Bild/Deps/nostr-rs-relay.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/Omni/Bild/Deps/nostr-rs-relay.nix b/Omni/Bild/Deps/nostr-rs-relay.nix
new file mode 100644
index 0000000..0eef13f
--- /dev/null
+++ b/Omni/Bild/Deps/nostr-rs-relay.nix
@@ -0,0 +1,19 @@
+{ fetchFromSourcehut, rustPlatform, pkg-config, openssl }:
+
+rustPlatform.buildRustPackage rec {
+ pname = "nostr-rs-relay";
+ version = "0.7.15";
+
+ src = fetchFromSourcehut {
+ owner = "~gheartsfield";
+ repo = pname;
+ rev = version;
+ sha256 = "sha256-aa1uFJcpQPMVzIWpkQ2MW6LIzTnhXNQc220scbzwJ5k=";
+ };
+
+ cargoSha256 = "sha256-3593pjc4A4NsEnE/ZYsR1vSMCvw2ZJue4EIY6cFa2WA=";
+
+ nativeBuildInputs = [ pkg-config openssl.dev ];
+
+ buildInputs = [ openssl.dev ];
+}