summaryrefslogtreecommitdiff
path: root/Que/Prod.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Que/Prod.nix')
-rw-r--r--Que/Prod.nix35
1 files changed, 30 insertions, 5 deletions
diff --git a/Que/Prod.nix b/Que/Prod.nix
index 23c6f0a..b755d7c 100644
--- a/Que/Prod.nix
+++ b/Que/Prod.nix
@@ -1,5 +1,22 @@
-{ config, pkgs, lib, ... }:
-{
+{ bild, lib }:
+
+# The production server for que.run
+
+bild.os {
+ imports = [
+ ../Biz/OsBase.nix
+ ../Biz/Packages.nix
+ ../Biz/Users.nix
+ ./Host.nix
+ ./Site.nix
+ ];
+ networking.hostName = "prod-que";
+ networking.domain = "que.run";
+ services.que-server = {
+ enable = true;
+ port = 80;
+ package = bild.ghc ./Host.hs;
+ };
boot.loader.grub.device = "/dev/vda";
fileSystems."/" = { device = "/dev/vda1"; fsType = "ext4"; };
swapDevices = [
@@ -30,7 +47,15 @@
};
};
};
- services.udev.extraRules = ''
- ATTR{address}=="7a:92:a5:c6:db:c3", NAME="eth0"
- '';
+ services = {
+ que-website = {
+ enable = true;
+ namespace = "_";
+ package = bild.ghc ./Site.hs;
+ };
+
+ udev.extraRules = ''
+ ATTR{address}=="7a:92:a5:c6:db:c3", NAME="eth0"
+ '';
+ };
}