summaryrefslogtreecommitdiff
path: root/Run/Que/Server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Run/Que/Server.nix')
-rw-r--r--Run/Que/Server.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/Run/Que/Server.nix b/Run/Que/Server.nix
deleted file mode 100644
index e326483..0000000
--- a/Run/Que/Server.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-let
- cfg = config.services.que-server;
-in
-{
- options.services.que-server = {
- enable = lib.mkEnableOption "Enable the que-server service";
- port = lib.mkOption {
- type = lib.types.int;
- default = 3000;
- description = ''
- The port on which que-server will listen for
- incoming HTTP traffic.
- '';
- };
- package = lib.mkOption {
- type = lib.types.package;
- description = "que-server package to use";
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.que-server = {
- path = [ cfg.package ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ${cfg.package}/bin/que-server
- '';
- description = ''
- Que server
- '';
- serviceConfig = {
- Environment = ["QUE_PORT=${toString cfg.port}"];
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- };
-}