summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix19
1 files changed, 16 insertions, 3 deletions
diff --git a/configuration.nix b/configuration.nix
index a5cd2c6..83c449b 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -3,12 +3,13 @@
let
bensIp = "68.107.97.20";
ibbPort = "3000";
+ fathomPort = "3030";
in
{
nixpkgs.config.allowUnfree = true;
- nixpkgs.config.packageOverrides = pkgs: {
- ibb = import ./ibb/default.nix {};
- };
+ nixpkgs.overlays = [
+ (import ./pack/default.nix)
+ ];
networking.firewall.allowedTCPPorts = [ 22 80 443 ];
@@ -19,6 +20,12 @@ in
port = ibbPort;
};
+ fathom = {
+ enable = true;
+ port = fathomPort;
+ dataDir = "/var/lib/fathom";
+ };
+
nginx = {
enable = true;
recommendedGzipSettings = true;
@@ -30,6 +37,12 @@ in
"dev.simatime.com".locations."/".proxyPass = "http://${bensIp}:${ibbPort}";
"hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
"tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
+
+ "stats.simatime.com" = {
+ locations."/".proxyPass = "http://localhost:${fathomPort}";
+ forceSSL = true;
+ enableACME = true;
+ };
"influencedbybooks.com" = {
forceSSL = true;
enableACME = true;