summaryrefslogtreecommitdiff
path: root/depo/nutin-madaj/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'depo/nutin-madaj/default.nix')
-rw-r--r--depo/nutin-madaj/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/depo/nutin-madaj/default.nix b/depo/nutin-madaj/default.nix
index b2afae8..4d9dd02 100644
--- a/depo/nutin-madaj/default.nix
+++ b/depo/nutin-madaj/default.nix
@@ -54,6 +54,13 @@ nixos {
withUtempter = true;
};
+ services.openssh = {
+ enable = true;
+ passwordAuthentication = false;
+ };
+
+ security.sudo.wheelNeedsPassword = true;
+
# our custom apps
#services = {
# ibb = {
@@ -83,6 +90,5 @@ nixos {
#};
boot.cleanTmpDir = true;
- services.openssh.enable = true;
};
}