summaryrefslogtreecommitdiff
path: root/depo/nutin-madaj/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'depo/nutin-madaj/networking.nix')
-rw-r--r--depo/nutin-madaj/networking.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/depo/nutin-madaj/networking.nix b/depo/nutin-madaj/networking.nix
deleted file mode 100644
index 4cfd73d..0000000
--- a/depo/nutin-madaj/networking.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ lib, ... }: {
- networking = {
-
- hostName = "simatime";
-
- firewall = {
- allowedTCPPorts = [ 22 80 443 ];
- allowPing = true;
- };
-
- # This following was populated at runtime with the networking details
- # gathered from the active system.
- nameservers = [
- "67.207.67.2"
- "67.207.67.3"
- ];
- defaultGateway = "159.89.128.1";
- defaultGateway6 = "";
- dhcpcd.enable = false;
- usePredictableInterfaceNames = lib.mkForce true;
- interfaces = {
- eth0 = {
- ipv4.addresses = [
- { address="159.89.128.69"; prefixLength=20; }
-{ address="10.46.0.6"; prefixLength=16; }
- ];
- ipv6.addresses = [
- { address="fe80::e899:c0ff:fe9c:e194"; prefixLength=64; }
- ];
- };
-
- };
- };
- services.udev.extraRules = ''
- ATTR{address}=="ea:99:c0:9c:e1:94", NAME="eth0"
-
- '';
-}