summaryrefslogtreecommitdiff
path: root/nix/haskell-overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/haskell-overlay.nix')
-rw-r--r--nix/haskell-overlay.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/nix/haskell-overlay.nix b/nix/haskell-overlay.nix
deleted file mode 100644
index a6aad12..0000000
--- a/nix/haskell-overlay.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-_: pkgs:
-
-let
- simpleCabalBuilder = self: name:
- self.callCabal2nix name pkgs.sources.${name} {};
- buildCabal = self: name: subdir:
- if isNull subdir then
- self.callCabal2nix name pkgs.sources.${name} {}
- else
- self.callCabal2nix name (pkgs.sources.${name} + "/${subdir}") {};
-in
-{
- haskell = pkgs.haskell // {
- packages = pkgs.haskell.packages // {
- ghc865 = pkgs.haskell.packages.ghc865.override (old: {
- overrides = with pkgs.pkgs.haskell.lib; self: super:
- pkgs.overridePinnedDeps (simpleCabalBuilder self) // {
- acid-state = dontCheck super.acid-state; # mac: "too many open files"
- servant-auth = buildCabal self "servant-auth" "servant-auth";
- wai-middleware-metrics = dontCheck super.wai-middleware-metrics;
- };
- });
- ghcjs = pkgs.haskell.packages.ghcjs.override (old: {
- overrides = with pkgs.haskell.lib; self: super:
- pkgs.overridePinnedDeps (simpleCabalBuilder self) // {
- Glob = dontCheck super.Glob;
- QuickCheck = dontCheck super.QuickCheck;
- base-compat-batteries = dontCheck super.http-types;
- clay = dontCheck super.clay;
- comonad = dontCheck super.comonad;
- jsaddle-warp = dontCheck (self.callCabal2nix "jsaddle-warp" "${pkgs.sources.jsaddle}/jsaddle-warp" {});
- http-types = dontCheck super.http-types;
- network-uri= dontCheck super.network-uri;
- scientific = dontCheck super.scientific; # takes forever
- servant = dontCheck super.servant;
- servant-auth = buildCabal self "servant-auth" "servant-auth";
- tasty-quickcheck = dontCheck super.tasty-quickcheck;
- time-compat = dontCheck super.time-compat;
- };
- });
- };
- };
-}