summaryrefslogtreecommitdiff
path: root/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos.nix')
-rw-r--r--nixos.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nixos.nix b/nixos.nix
new file mode 100644
index 0000000..cc76470
--- /dev/null
+++ b/nixos.nix
@@ -0,0 +1,16 @@
+# Nix config for the main biz machine.
+
+let
+ nixpkgs = fetchGit (import ./pkgs.nix);
+in
+import "${nixpkgs}/nixos" {
+ system = "x86_64-linux";
+ configuration = {
+ imports = [
+ ./hardware-configuration.nix
+ ./networking.nix
+ ./configuration.nix
+ ./ibb/module.nix
+ ];
+ };
+}