summaryrefslogtreecommitdiff
path: root/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlay.nix')
-rw-r--r--overlay.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/overlay.nix b/overlay.nix
new file mode 100644
index 0000000..77bf9b4
--- /dev/null
+++ b/overlay.nix
@@ -0,0 +1,50 @@
+self: super:
+
+let
+ claySrc = super.pkgs.fetchFromGitHub {
+ owner = "sebastiaanvisser";
+ repo = "clay";
+ rev = "cc7729b1b42a79e261091ff7835f7fc2a7ae3cee";
+ sha256 = "1vd67976lvi5l4qq18zy6j44apynkl44ps04p8vwfx4gzr895dyp";
+ };
+in {
+ haskell = super.haskell // {
+ packages = super.haskell.packages // {
+ ghc865 = super.haskell.packages.ghc865.override (old: {
+ overrides = with super.pkgs.haskell.lib; self: super: {
+ clay = self.callCabal2nix "clay" claySrc {};
+ wai-middleware-metrics = dontCheck super.wai-middleware-metrics;
+ };
+ });
+ ghcjs = super.haskell.packages.ghcjs.override (old: {
+ overrides = with super.haskell.lib; self: super: {
+ QuickCheck = dontCheck super.QuickCheck;
+ base-compat-batteries = dontCheck super.http-types;
+ clay = dontCheck (self.callCabal2nix "clay" claySrc {});
+ comonad = dontCheck super.comonad;
+ http-types = dontCheck super.http-types;
+ network-uri= dontCheck super.network-uri;
+ scientific = dontCheck super.scientific; # takes forever
+ servant = dontCheck super.servant;
+ tasty-quickcheck = dontCheck super.tasty-quickcheck;
+ time-compat = dontCheck super.time-compat;
+ };
+ });
+ };
+ };
+ wemux = super.stdenv.mkDerivation rec {
+ name = "wemux";
+ version = "2020.04.03";
+ src = super.pkgs.fetchFromGitHub {
+ owner = "zolrath";
+ repo = "wemux";
+ rev = "01c6541f8deceff372711241db2a13f21c4b210c";
+ sha256 = "1y962nzvs7sf720pl3wa582l6irxc8vavd0gp4ag4243b2gs4qvm";
+ };
+ installPhase = ''
+ mkdir -p $out/bin
+ cp ${src}/wemux $out/bin
+ chmod +x $out/bin/wemux
+ '';
+ };
+}