summaryrefslogtreecommitdiff
path: root/pack/bs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pack/bs.nix')
-rw-r--r--pack/bs.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/pack/bs.nix b/pack/bs.nix
deleted file mode 100644
index d869dd1..0000000
--- a/pack/bs.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ nixpkgs }:
-with nixpkgs;
-let
- ghc = pkgs.haskell.packages.ghc844.ghcWithPackages (hp: with hp; [
- hinotify
-
- containers
- directory
- haskeline
- HTTP
- mtl
- optparse-applicative
- parsec
- protolude
- text
- transformers
- wl-pprint-text
- ]);
- entrypoint = "Bs";
-in
-stdenv.mkDerivation rec {
- name = "bs";
- version = "0";
- src = ../.;
- nativeBuildInputs = [
- ghc
- ];
- strictDeps = true;
- buildPhase = ''
- ${ghc}/bin/ghc \
- -iapex -ilore \
- -main-is ${entrypoint} --make apex/${entrypoint}.hs \
- -o bild/${name}
- '';
- installPhase = ''
- mkdir -p $out/bin
- cp bild/${name} $out/bin/${name}
- '';
-}