summaryrefslogtreecommitdiff
path: root/pack/duree.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pack/duree.nix')
-rw-r--r--pack/duree.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pack/duree.nix b/pack/duree.nix
new file mode 100644
index 0000000..84b82da
--- /dev/null
+++ b/pack/duree.nix
@@ -0,0 +1,33 @@
+{ nixpkgs }:
+with nixpkgs;
+let
+ ghc = pkgs.haskell.packages.ghc844.ghcWithPackages (hp: with hp; [
+ hinotify
+
+ mongoDB
+ mtl
+ protolude
+ text
+ transformers
+ ]);
+ entrypoint = "Duree";
+in
+stdenv.mkDerivation rec {
+ name = "duree";
+ version = "0";
+ src = ../.;
+ nativeBuildInputs = [
+ ghc
+ ];
+ strictDeps = true;
+ buildPhase = ''
+ ${ghc}/bin/ghc \
+ -iapex -ilore \
+ -main-is ${entrypoint} --make apex/${entrypoint}.hs \
+ -o bild/${name}
+ '';
+ installPhase = ''
+ mkdir -p $out/bin
+ cp bild/${name} $out/bin/${name}
+ '';
+}