summaryrefslogtreecommitdiff
path: root/pack/ibb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pack/ibb.nix')
-rw-r--r--pack/ibb.nix51
1 files changed, 29 insertions, 22 deletions
diff --git a/pack/ibb.nix b/pack/ibb.nix
index ba4cae7..6d3e820 100644
--- a/pack/ibb.nix
+++ b/pack/ibb.nix
@@ -1,23 +1,30 @@
-{ compiler ? "ghc843"
-, doHaddock ? false
-, doBenchmark ? false
-, doCheck ? true
-, withHoogle ? false
-, nixpkgs ? builtins.fetchTarball (import ./nixpkgs.nix)
-}:
-
-with import "${nixpkgs}" {};
-
-haskell.packages.${compiler}.developPackage {
- root = ../.;
- overrides = with haskell.lib; self: super: {
- ghc =
- if withHoogle
- then super.ghc // {withPackages = super.ghc.withHoogle;}
- else super.ghc;
- ghcWithPackages =
- if withHoogle
- then self.ghc.withPackages
- else super.ghcWithPackages;
- };
+{ nixpkgs }:
+with nixpkgs;
+let
+ ghc = pkgs.haskell.packages.ghc844.ghcWithPackages (hp: with hp; [
+ blaze-html
+ blaze-markup
+ bytestring
+ random
+ random-shuffle
+ scotty
+ shakespeare
+ text
+ ]);
+in
+stdenv.mkDerivation rec {
+ name = "ibb";
+ version = "0";
+ src = ../.;
+ nativeBuildInputs = [
+ ghc
+ ];
+ strictDeps = true;
+ buildPhase = ''
+ ${ghc}/bin/ghc -iapex -ilore -main-is Ibb --make apex/Ibb.hs -o bild/${name}
+ '';
+ installPhase = ''
+ mkdir -p $out/bin
+ cp bild/${name} $out/bin/${name}
+ '';
}