summaryrefslogtreecommitdiff
path: root/pack/ibb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pack/ibb.nix')
-rw-r--r--pack/ibb.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pack/ibb.nix b/pack/ibb.nix
new file mode 100644
index 0000000..ba4cae7
--- /dev/null
+++ b/pack/ibb.nix
@@ -0,0 +1,23 @@
+{ compiler ? "ghc843"
+, doHaddock ? false
+, doBenchmark ? false
+, doCheck ? true
+, withHoogle ? false
+, nixpkgs ? builtins.fetchTarball (import ./nixpkgs.nix)
+}:
+
+with import "${nixpkgs}" {};
+
+haskell.packages.${compiler}.developPackage {
+ root = ../.;
+ overrides = with haskell.lib; self: super: {
+ ghc =
+ if withHoogle
+ then super.ghc // {withPackages = super.ghc.withHoogle;}
+ else super.ghc;
+ ghcWithPackages =
+ if withHoogle
+ then self.ghc.withPackages
+ else super.ghcWithPackages;
+ };
+}