summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-11-10 08:03:04 -0800
committerBen Sima <ben@bsima.me>2018-11-10 08:03:04 -0800
commit16fe00c223c6148a01939b5ca61b55b2ce6d3a50 (patch)
tree22a8639a72a261d1aa75e89955e36317e839d3fd /common.nix
parent73c21612f5136376f09dad2e2834f948e796a834 (diff)
Movew afew.ini to own file
nix-format-buffer (M-Q) will mess up the indentation in the query stanza, so for now just put this elsewhere.
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix51
1 files changed, 1 insertions, 50 deletions
diff --git a/common.nix b/common.nix
index 6178c57..0886747 100644
--- a/common.nix
+++ b/common.nix
@@ -302,56 +302,7 @@ in
afew = {
enable = true;
- extraConfig = ''
- [ArchiveSentMailsFilter]
-
- [SpamFilter]
- spam_tag = spam
-
- # This filter looks for the List-Id header, and if it finds it, adds a
- # tag lists and a tag named lists/<list-id>.
- [ListMailsFilter]
-
- [Filter.0]
- message = mobile todos
- query = 'from:ben@bsima.me AND to:ben@bsima.me AND subject:TODO'
- tags = +todo;-inbox;+unread
-
- [Filter.1]
- message = logwatch
- query = subject:Logwatch
- tags = +logwatch;-new;-inbox
-
- [Filter.2]
- message = newsletters
- query =
- from:the-morning-paper@onelanday.co.uk OR
- from:newsletter@fightaging.org OR
- from:newsletter@fightaging.org or
- subject:'The Reading List Email*' OR
- from:info@haskellweekly.news OR
- from:kale@hackernewsletter.com OR
- from:newsletter@farnamstreetblog.com
- tags = -unread +deals
-
- [Filter.3]
- message = job emails
- query =
- from:alist.co OR
- from:angel.co OR
- from:stackoverflow.com OR
- from:stackoverflow.email OR
- from:cdmtechnology.com OR
- subject:job
- tags = +jobs;-inbox
-
- [Filter.4]
- message = github
- query = from:github.com
- tags = +github;-inbox
-
- [InboxFilter]
- '';
+ extraConfig = builtins.readFile ./afew.ini;
};
mbsync = {