summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-01-07 08:47:06 -0800
committerBen Sima <ben@bsima.me>2019-01-11 11:13:05 -0800
commit22fdde6d840e408984f22c08424c34e06b594095 (patch)
treede05e1395f5564d3361cbb3d779955530d7ea220 /common.nix
parent25c5d28d15bd95d532f0c3ff27f5e95fdb4e969d (diff)
Add experimental cd function
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index ff58399..2f23e95 100644
--- a/common.nix
+++ b/common.nix
@@ -89,6 +89,9 @@ in
DIR=~/.nix-profile/etc/profile.d
[[ -f "$DIR/nix.sh" ]] && . "$DIR/nix.sh"
[[ -f "$DIR/hm-session-vars.sh" ]] && . "$DIR/hm-session-vars.sh"
+ function cd() {
+ builtin cd "$@" && ls
+ }
'';
shellAliases = {
#z = "fasd_cd -d"; # cd, same functionality as j in autojump