summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-06-13 10:17:34 -0700
committerBen Sima <ben@bsima.me>2019-06-13 10:23:13 -0700
commit2da7999816b7d0db3e47d1cef34a3963882a76da (patch)
treeebf157001671d925f4620a0bc3c956b46df5b037 /common.nix
parent68aaa0a93861413567da43318a8bde2533ac0d82 (diff)
move tmux to nix config
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix16
1 files changed, 12 insertions, 4 deletions
diff --git a/common.nix b/common.nix
index eec499a..d23b238 100644
--- a/common.nix
+++ b/common.nix
@@ -32,10 +32,6 @@ in
source = ./mailcap;
target = ".mailcap";
};
- tmux = {
- source = ./tmux;
- target = ".tmux.conf";
- };
};
};
@@ -45,6 +41,18 @@ in
path = "${homedir}/cfg/home-manager";
};
+ tmux = {
+ enable = true;
+ extraConfig = builtins.readFile ./tmux;
+ baseIndex = 0;
+ clock24 = true;
+ customPaneNavigationAndResize = true;
+ keyMode = "vi";
+ shortcut = "'C-\\'";
+ terminal = "screen-256color";
+ sensibleOnTop = true;
+ };
+
ssh = {
enable = true;
forwardAgent = true;