summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-07-10 11:03:55 -0700
committerBen Sima <ben@bsima.me>2019-07-10 11:03:55 -0700
commit6b64f05a4063d09d6b11b13b5496c021c8c69460 (patch)
treedf63be6a89931457ee3f66f4c5a4d15c08fb88e2 /common.nix
parentbf1825677bf32694235c337093b311fa080dded6 (diff)
move git config out of common.nix
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/common.nix b/common.nix
index 332b308..9c54a76 100644
--- a/common.nix
+++ b/common.nix
@@ -4,7 +4,6 @@ let
homedir = builtins.getEnv "HOME";
locale = "en_US.UTF-8";
gpgid = "D09299626FA78AF8";
- gitCommitTemplate = ./git-commit-template;
in
{
home = {
@@ -110,35 +109,6 @@ in
extraConfig = builtins.readFile ./vimrc;
};
- git = {
- enable = true;
- userName = "Ben Sima";
- userEmail = "ben@bsima.me";
- ignores = [ "*~" "*.swp" ];
- package = pkgs.gitAndTools.gitFull;
- signing = {
- key = gpgid;
- signByDefault = false;
- };
- aliases = {
- authors = "shortlog -s -n";
- };
- extraConfig = ''
- [push]
- default = simple
-
- [commit]
- template = ${gitCommitTemplate}
-
- [sendemail]
- smtpuser = ben@bsima.me
- smptserverport = 587
- smptserver = mail.bsima.me
- chainreplyto = false
- composeencoding = UTF-8
- '';
- };
-
bash = {
enable = true;
initExtra = ''