summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-05-13 13:13:10 -0700
committerBen Sima <ben@bsima.me>2019-05-13 13:13:10 -0700
commit6ea923ef95f99c99b2b3a53c9a7132de44b0bbc6 (patch)
treea2f9d007a105120985f1b0a97be1f5d49eba216c /common.nix
parent7c499899ef1c0c4acbd5ea2e98294436c6a03284 (diff)
activate skim
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index a48eb94..c828a99 100644
--- a/common.nix
+++ b/common.nix
@@ -49,6 +49,11 @@ in
enable = true;
};
+ skim = {
+ enable = true;
+ enableBashIntegration = true;
+ };
+
vim = {
enable = true;
plugins = [
@@ -138,6 +143,8 @@ in
typeless = "history | tail -n 20000 | sed 's/.* //' | sort | uniq -c | sort -g | tail -n 100";
v = "vim";
"v." = "vim .";
+ vs = "vim $(sk -m)";
+ vk = "vim $(sk -m)";
vimdiff = "vim -d";
};
};