summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-22 12:19:43 -0700
committerBen Sima <ben@bsima.me>2019-04-22 12:19:43 -0700
commit7257fa93373ca948e858c920ec0bd499a4543f45 (patch)
tree2cb3fc9530436ac91f510b5044d2b70d3edca5cb /common.nix
parent059466e9e9d8ff8bde6f80db75bc52af1b281132 (diff)
add new gpg key
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 7fe0094..11c5d16 100644
--- a/common.nix
+++ b/common.nix
@@ -3,11 +3,13 @@
let
homedir = builtins.getEnv "HOME";
locale = "en_US.UTF-8";
+ gpgid = "D09299626FA78AF8";
in
{
home = {
packages = import ./packages.nix { inherit pkgs; };
sessionVariables = {
+ GPGID = gpgid;
EDITOR = "emacsclient";
LANG = locale;
LANGUAGE = locale;
@@ -69,6 +71,10 @@ in
userEmail = "ben@bsima.me";
ignores = [ "*~" "*.swp" ];
package = pkgs.gitAndTools.gitFull;
+ signing = {
+ key = gpgid;
+ signByDefault = true;
+ };
aliases = {
authors = "shortlog -s -n";
};