summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-05-23 15:11:54 -0700
committerBen Sima <ben@bsima.me>2019-05-23 15:11:54 -0700
commit868aac8c30897423c2e65ab4c94e017a8e4b892a (patch)
tree830df4fd158a472ae69a94152563b774d7821058 /common.nix
parent4294df8a48cd6026ad64373af5de585d8ac70ad1 (diff)
setup distributed builds over ssh
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index c828a99..23c5244 100644
--- a/common.nix
+++ b/common.nix
@@ -45,6 +45,25 @@ in
path = "${homedir}/cfg/home-manager";
};
+ ssh = {
+ enable = true;
+ forwardAgent = true;
+ matchBlocks = {
+ hidor-kahih = {
+ hostname = "home.simatime.com";
+ user = "ben";
+ identityFile = [ "${homedir}/.ssh/hidor-kahih" ];
+ identitiesOnly = true;
+ };
+ nutin-madaj = {
+ hostname = "simatime.com";
+ user = "ben";
+ identityFile = [ "${homedir}/.ssh/id_rsa" ];
+ identitiesOnly = true;
+ };
+ };
+ };
+
direnv = {
enable = true;
};