summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-07-05 23:12:45 -0700
committerBen Sima <ben@bsima.me>2019-07-06 10:21:20 -0700
commitb77052835604ece8bce1975779eef8f4f9e5f34e (patch)
tree04610f6944c201e0e3b4cc626fa0eed1532ef4ed /common.nix
parent80a762dce45dff6bd5fb60869072013288b99e01 (diff)
simple bash prompt in blue
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 8429b87..a80a165 100644
--- a/common.nix
+++ b/common.nix
@@ -157,6 +157,9 @@ in
function cd() {
builtin cd "$@" && ls
}
+
+ # my prompt, after much chagrin
+ export PS1='\n\[\e[34m\][\u@\h:\w]\[\e[m\] $(date +%Y.%m.%d..%H.%M) \n$ '
'';
shellAliases = {
#z = "fasd_cd -d"; # cd, same functionality as j in autojump