summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-03-22 16:32:24 -0700
committerBen Sima <ben@bsima.me>2019-03-22 16:32:24 -0700
commitd1443586e94b89ee21b4609f6aa4d4077e5a4cbf (patch)
treef341f1eee4b75bc2da5ea0f7484f1826557ff6b6 /common.nix
parent02916834d1d6a829ef1f72567f487465e841b0af (diff)
Trying to get rofi to work, still doesn't work with xmonad
I can launch rofi from the terminal but the xmonad keys don't work, and I have no idea why.
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/common.nix b/common.nix
index e872492..beb0b57 100644
--- a/common.nix
+++ b/common.nix
@@ -2,17 +2,21 @@
let
homedir = builtins.getEnv "HOME";
+ locale = "en_US.UTF-8";
in
{
home = {
packages = import ./packages.nix { inherit pkgs; };
sessionVariables = {
EDITOR = "emacsclient";
- LANG = "en_US.UTF-8";
+ LANG = locale;
+ LANGUAGE = locale;
+ #LC_ALL = locale;
PATH = "${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
PAGER = "less";
LEDGER_FILE = "${homedir}/.hledger.journal";
- XTERM_LOCALE = "en_US.UTF-8";
+ XTERM_LOCALE = locale;
+ LOCALE_ARCHIVE = "${pkgs.glibcLocales}/lib/locale/locale-archive";
};
keyboard.options = [ "caps:ctrl_modifier" ];
file = {