summaryrefslogtreecommitdiff
path: root/darwin.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-10-30 12:06:44 -0400
committerBen Sima <ben@bsima.me>2020-10-30 12:06:44 -0400
commit46da79cb9474bc1280cc5a1ff4124956af00742b (patch)
tree402e9e0c03df195a6ac0ddde0bcc76256b1bf62b /darwin.nix
parent6b2c03d3bb8ac1de2d9431fe08c12b45ec193695 (diff)
Move some email settings around
Diffstat (limited to 'darwin.nix')
-rw-r--r--darwin.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/darwin.nix b/darwin.nix
index d91c25e..c278623 100644
--- a/darwin.nix
+++ b/darwin.nix
@@ -6,8 +6,20 @@ let
gpgid = "D09299626FA78AF8";
in
{
- imports = [ ./lib/common.nix ];
- home.sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
+ imports = [
+ ./lib/common.nix
+ ./lib/email.nix
+ ];
+ home = {
+ sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
+ packages = with pkgs; [
+ muchsync
+ hledger-web
+ hledger-ui
+ (haskellPackages.ghcWithPackages (ps: with ps; [hledger]))
+ ];
+ };
+
programs = {
git = {
@@ -43,6 +55,5 @@ in
enable = true;
extraPackages = epkgs: import ./lib/emacs-packages.nix { inherit epkgs; };
};
-
};
}