summaryrefslogtreecommitdiff
path: root/darwin.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-05-16 09:49:15 -0400
committerBen Sima <ben@bsima.me>2021-05-16 09:49:15 -0400
commitfa8a6f493f1b5060fa306e39a5502df56f4f02c1 (patch)
treee1dbd7a4dbd9acb48e4745527de3927ba6880244 /darwin.nix
parentd2b49d5dda113d42a4d221be36ee3298c43350d3 (diff)
move stuff into profiles
Diffstat (limited to 'darwin.nix')
-rw-r--r--darwin.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/darwin.nix b/darwin.nix
deleted file mode 100644
index c221e9e..0000000
--- a/darwin.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ pkgs, ... }:
-
-let
- homedir = builtins.getEnv "HOME";
- haskellOverlay = self: super: {
- haskellPackages = super.haskellPackages.override (old: {
- overrides = self: super: {
- hledger = self.callPackage ./pkgs/hledger-1.19.1.nix {};
- hledger-lib = self.callPackage ./pkgs/hledger-lib-1.19.1.nix {};
- };
- });
- };
-in
-{
- nixpkgs.overlays = [
- haskellOverlay
- ];
-
- imports = [
- ./lib/common.nix
- ./lib/email.nix
- ];
- home = {
- sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
- packages = with pkgs; [
- muchsync
- (haskellPackages.ghcWithPackages (ps: with ps; [hledger]))
- coreutils
- ];
- };
-
- programs = {
-
- # Doesnt' work bc clang can't compile it??
- #qutebrowser = {
- # enable = true;
- # settings = {
- # "colors.webpage.darkmode.enabled" = true;
- # };
- #};
-
- };
-}