summaryrefslogtreecommitdiff
path: root/email.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-17 03:07:45 -0800
committerBen Sima <ben@bsima.me>2019-02-17 03:07:45 -0800
commit6469b5dd163b9b7784a81d42696491f0859d0ea3 (patch)
tree9e914faf9f1cc26b1bbffe4317e478285ed48931 /email.nix
parentae489341894937d904cb1e7057c5cf1585b898ae (diff)
Get connected to simatime.com mailserver
Diffstat (limited to 'email.nix')
-rw-r--r--email.nix24
1 files changed, 22 insertions, 2 deletions
diff --git a/email.nix b/email.nix
index 7add712..f085943 100644
--- a/email.nix
+++ b/email.nix
@@ -30,9 +30,30 @@ in
expunge = "none";
};
notmuch.enable = true;
- msmtp.enable = false;
+ msmtp.enable = true;
passwordCommand = "pass bnet/helium/mail/ben";
};
+ "ben@simatime.com" = {
+ realName = "Ben Sima";
+ address = "ben@simatime.com";
+ userName = "ben@simatime.com";
+ imap = {
+ host = "mail.simatime.com";
+ port = 993;
+ };
+ smtp = {
+ host = "mail.simatime.com";
+ port = 587;
+ };
+ mbsync = {
+ enable = true;
+ create = "both";
+ expunge = "none";
+ };
+ notmuch.enable = true;
+ passwordCommand = "pass simatime/mail/ben";
+ msmtp.enable = true;
+ };
};
};
};
@@ -72,7 +93,6 @@ in
msmtp = {
enable = false;
- extraConfig = builtins.readFile ./msmtprc;
};
};
}