summaryrefslogtreecommitdiff
path: root/email.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-22 12:19:43 -0700
committerBen Sima <ben@bsima.me>2019-04-22 12:19:43 -0700
commit7257fa93373ca948e858c920ec0bd499a4543f45 (patch)
tree2cb3fc9530436ac91f510b5044d2b70d3edca5cb /email.nix
parent059466e9e9d8ff8bde6f80db75bc52af1b281132 (diff)
add new gpg key
Diffstat (limited to 'email.nix')
-rw-r--r--email.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/email.nix b/email.nix
index 5657cf0..ff74ff3 100644
--- a/email.nix
+++ b/email.nix
@@ -2,6 +2,7 @@
let
homedir = builtins.getEnv "HOME";
+ gpgid = "D09299626FA78AF8";
in
{
accounts = {
@@ -24,6 +25,11 @@ in
host = "mail.bsima.me";
port = 587;
};
+ gpg = {
+ key = gpgid;
+ signByDefault = true;
+ encryptByDefault = false;
+ };
userName = "ben@bsima.me";
mbsync = {
enable = true;