summaryrefslogtreecommitdiff
path: root/groq.nix
diff options
context:
space:
mode:
authorBen Sima <bsima@groq.com>2019-06-11 13:37:25 -0700
committerBen Sima <ben@bsima.me>2019-07-09 15:49:50 -0700
commit0176935d1d53b71555b4809d08b1195fe80c4b2e (patch)
tree97a823a76e3a32bb5663b1a0056ffd84d123bf1c /groq.nix
parentfc1329fc2fa4d94f5881d7079c0190d28b0796ce (diff)
refactor for and setup groq machine
Diffstat (limited to 'groq.nix')
-rw-r--r--groq.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/groq.nix b/groq.nix
new file mode 100644
index 0000000..f30d188
--- /dev/null
+++ b/groq.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }:
+
+let
+ gitCommitTemplate = ./git-commit-template;
+in
+{
+ imports = [
+ ./common.nix
+ ];
+ programs = {
+ emacs = {
+ enable = true;
+ extraPackages = epkgs: import ./emacs-packages.nix { inherit epkgs; };
+ };
+
+ git = {
+ enable = true;
+ userName = "Ben Sima";
+ userEmail = "bsima@groq.com";
+ ignores = [ "*~" "*.swp" ];
+ package = pkgs.gitAndTools.gitFull;
+ extraConfig = ''
+ [push]
+ default = simple
+
+ [commit]
+ template = ${gitCommitTemplate}
+ '';
+ };
+
+ };
+}