summaryrefslogtreecommitdiff
path: root/groq.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-05-16 09:49:15 -0400
committerBen Sima <ben@bsima.me>2021-05-16 09:49:15 -0400
commitfa8a6f493f1b5060fa306e39a5502df56f4f02c1 (patch)
treee1dbd7a4dbd9acb48e4745527de3927ba6880244 /groq.nix
parentd2b49d5dda113d42a4d221be36ee3298c43350d3 (diff)
move stuff into profiles
Diffstat (limited to 'groq.nix')
-rw-r--r--groq.nix73
1 files changed, 0 insertions, 73 deletions
diff --git a/groq.nix b/groq.nix
deleted file mode 100644
index d1214b3..0000000
--- a/groq.nix
+++ /dev/null
@@ -1,73 +0,0 @@
-{ pkgs, ... }:
-
-let
- gitCommitTemplate = ./git-commit-template;
-in
-{
- imports = [
- ./common.nix
- ];
-
- accounts = {
- email = {
- maildirBasePath = "mail";
- accounts = {
- "groq" = {
- primary = true;
- flavor = "gmail.com";
- realName = "Ben Sima";
- address = "bsima@groq.com";
- userName = "bsima@groq.com";
- mbsync = {
- enable = true;
- create = "both";
- expunge = "none";
- };
- notmuch.enable = true;
- msmtp.enable = true;
- passwordCommand = "secret-tool lookup email bsima@groq.io";
- };
- };
- };
- };
-
- services.emacs.enable = true;
-
- programs = {
- emacs = {
- enable = true;
- };
-
- git = {
- enable = true;
- userName = "Ben Sima";
- userEmail = "bsima@groq.com";
- ignores = [ "*~" "*.swp" ];
- package = pkgs.gitAndTools.gitFull;
- extraConfig = ''
- [push]
- default = simple
-
- [commit]
- template = ${gitCommitTemplate}
- '';
- };
-
- mbsync.enable = true;
- msmtp.enable = true;
-
- notmuch = {
- enable = true;
- new.tags = ["new"];
- hooks = {};
- extraConfig.search.exclude_tags = "deleted;spam;";
- };
-
- alot = {
- enable = true;
- extraConfig = ''
- theme = solarized_light
- '';
- };
- };
-}