summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-09-18 12:08:25 -0700
committerBen Sima <ben@bsima.me>2018-09-21 08:45:18 -0700
commit10497683ddabf318c56b9834e570c1407040b2d6 (patch)
treeed460a9f79661dc0046a6f2a89865fbbe59e239d /home.nix
parent059cd5bb8e4da39e3f5148f3129c1dff2ac2ec37 (diff)
Replace '~' with full path to $HOME in $PATH
Apparently, the '~' doesn't expand to $HOME on macOS, and presumably on other systems too.
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/home.nix b/home.nix
index 14af2ee..44c27eb 100644
--- a/home.nix
+++ b/home.nix
@@ -2,6 +2,7 @@
let
solarized-xresources = ./xresources;
+ homedir = builtins.getEnv "HOME";
in
{
# Waiting for the accounts feature to land in the 18.03 release branch...
@@ -38,7 +39,7 @@ in
sessionVariables = {
EDITOR = "vim";
LANG = "en_US.UTF-8";
- PATH = "~/bin:~/.cabal/bin:~/.local/bin:$PATH";
+ PATH = "${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
PAGER = "less";
};
file = {