summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-05-18 14:53:21 -0700
committerBen Sima <ben@bsima.me>2018-05-18 14:53:21 -0700
commite194f1a407c1033696a9084225e2d24ead686727 (patch)
treec297d6a7b05615375bf7c13653baf7aca081d750 /home.nix
parent2d6e0812fe9579a1ccf77f0172b3c03606f587e0 (diff)
Add git stuff
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home.nix b/home.nix
index d2af0cc..a2e9e72 100644
--- a/home.nix
+++ b/home.nix
@@ -38,6 +38,23 @@
pkgs.youtube-dl
];
+ programs.git = {
+ enable = true;
+ userName = "Ben Sima";
+ userEmail = "ben@bsima.me";
+ extraConfig = ''
+[push]
+ default = simple
+[branch "master]
+ remote = upstream
+ merge = refs/heads/master
+[remote]
+ pushDefault = origin
+[commit]
+ template = ~/.config/nixpkgs/git-commit-template
+ '';
+ };
+
programs.bash = {
enable = true;
shellAliases = {