summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-07-05 19:10:44 -0700
committerBen Sima <ben@bsima.me>2018-07-05 19:10:44 -0700
commite53ad06acfbd2c9195ef8d57ed3b31b3c224c741 (patch)
tree3ff1d38cf54b8be4735539fad8f24fd125d170f9 /home.nix
parent2a19f3f1e7b29c2cf532c724d59dfe090d0903ee (diff)
Add accounts
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/home.nix b/home.nix
index ecc5464..093722e 100644
--- a/home.nix
+++ b/home.nix
@@ -4,6 +4,35 @@ let
solarized-xresources = ./xresources;
in
{
+ # Waiting for the accounts feature to land in the 18.03 release branch...
+ #
+ #accounts = {
+ # email = {
+ # maildirBasePath = "$HOME/Mail";
+ # accounts = {
+ # "ben@bsima.me" = {
+ # primary = true;
+ # realName = "Ben Sima";
+ # address = "ben@bsima.me";
+ # folders = {
+ # inbox = "INBOX";
+ # };
+ # imap = {
+ # host = "mail.bsima.me";
+ # port = 993;
+ # };
+ # smtp = {
+ # host = "mail.bsima.me";
+ # port = 587;
+ # };
+ # userName = "ben@bsima.me";
+ # mbsync.enable = true;
+ # notmuch.enable = true;
+ # passwordCommand = "pass bnet/helium/mail/ben";
+ # };
+ # };
+ # };
+ #};
home = {
packages = import ./packages.nix { inherit pkgs; };
sessionVariables = {