summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-16 21:30:51 -0700
committerBen Sima <ben@bsima.me>2020-04-16 21:30:51 -0700
commit8c92bc399732c02721ed5432815b95c818e1b90b (patch)
treeafc2d4849dc9fc70f9a328ad263fc0487874714a /lib/common.nix
parentdb05fc6f13b9bb87b0c965e393d369ffa677bcd7 (diff)
Add python startup files
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 24e53e0..99cdbd8 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -18,6 +18,7 @@ in
LEDGER_FILE = "${homedir}/.hledger.journal";
XTERM_LOCALE = locale;
LOCALE_ARCHIVE = "${pkgs.glibcLocales}/lib/locale/locale-archive";
+ PYTHONSTARTUP = "${homedir}/.pythonrc";
};
# From the command line:
@@ -33,6 +34,14 @@ in
source = ./hledger.journal;
target = ".hledger.journal";
};
+ pythonrc = {
+ source = ./pythonrc;
+ target = ".pythonrc";
+ };
+ pdbrc = {
+ source = ./pythonrc;
+ target = ".pdbrc";
+ };
};
};