summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-11-12 20:24:55 -0800
committerBen Sima <ben@bsima.me>2019-11-12 20:27:25 -0800
commitb5cddf6cb8b2be7a4424753c30f82f74783bf896 (patch)
tree3baeea2fe9617bdb799bd7b5c3e83e1f06f5d778 /lib/common.nix
parent559a6038c4c91e3cf97bcf872ffc26c076622c69 (diff)
add serval
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix20
1 files changed, 14 insertions, 6 deletions
diff --git a/lib/common.nix b/lib/common.nix
index ea666f6..d6af79c 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -55,26 +55,34 @@ in
enable = true;
forwardAgent = true;
matchBlocks = {
+ "github.com" = {
+ hostname = "github.com";
+ user = "git";
+ identityFile = [ "${homedir}/.ssh/id_rsa" ];
+ identitiesOnly = true;
+ };
+
+
+ # simatime
"sabten" = {
hostname = "142.93.81.26";
user = "root";
identityFile = [ "${homedir}/.ssh/id_rsa" ];
identitiesOnly = true;
};
- "simatime.com" = {
- hostname = "simatime.com";
- user = "git";
+ "serval.simatime.com" = {
+ hostname = "serval.simatime.com";
+ user = "ben";
identityFile = [ "${homedir}/.ssh/id_rsa" ];
identitiesOnly = true;
};
- "github.com" = {
- hostname = "github.com";
+ "simatime.com" = {
+ hostname = "simatime.com";
user = "git";
identityFile = [ "${homedir}/.ssh/id_rsa" ];
identitiesOnly = true;
};
-
"lithium" = {
hostname = "192.168.1.9";
user = "ben";