summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-10-30 12:08:04 -0400
committerBen Sima <ben@bsima.me>2020-10-30 12:08:04 -0400
commitb68763894170464dd5d6d721f615004818b566be (patch)
treea0be15b7c1e3c312d776d2fe8cf23497eee05788 /lib/common.nix
parent41cf8d59330468c551e7f74b946d6eb285220e4d (diff)
Add hledger.journal and git.platonic.systems config
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/lib/common.nix b/lib/common.nix
index e383dc4..f84c5e8 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -30,7 +30,10 @@ in
target = ".editorconfig";
};
hledger = {
- source = ./hledger.journal;
+ source = builtins.toFile "hledger.journal" ''
+ !include ${homedir}/org/fund/accounts.journal
+ !include ${homedir}/org/fund/2019.10.journal
+ '';
target = ".hledger.journal";
};
pythonrc = {
@@ -113,6 +116,12 @@ in
identityFile = [ "${homedir}/.ssh/id_rsa" ];
identitiesOnly = true;
};
+ "git.platonic.systems" = {
+ hostname = "git.platonic.systems";
+ user = "git";
+ identityFile = [ "${homedir}/.ssh/platonic.systems" ];
+ identitiesOnly = true;
+ };
};
};