summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-14 11:09:31 -0500
committerBen Sima <ben@bsima.me>2020-11-14 11:11:28 -0500
commitff7fb253b24d63cd49a679630833a3d90b635af2 (patch)
tree89bbb56ee4b48dea78de3c78ed7740735a96561d /lib/common.nix
parentc9c230c28310e3147340fa7189bb99ee01eb2432 (diff)
Switch to neovim
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 429d6b7..f7a7d35 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -135,11 +135,12 @@ in
enable = true;
};
- vim = {
+ neovim = {
enable = true;
- plugins = with pkgs.vimPlugins; [
- editorconfig-vim
- ];
+ vimAlias = true;
+ viAlias = true;
+ vimdiffAlias = true;
+ plugins = [ pkgs.vimPlugins.editorconfig-vim ];
extraConfig = builtins.readFile ./vimrc;
};
@@ -198,9 +199,7 @@ in
tdate = "date +%Y.%m.%d..%H.%M";
ttime = "date +%H.%M";
typeless = "history | tail -n 20000 | sed 's/.* //' | sort | uniq -c | sort -g | tail -n 100";
- v = "vim";
"v." = "vim .";
- vimdiff = "vim -d";
vk = "vim $(sk -m)";
vs = "vim $(sk -m)";
};