summaryrefslogtreecommitdiff
path: root/lib/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-02-08 15:57:16 -0500
committerBen Sima <ben@bsima.me>2022-02-09 12:50:27 -0500
commit637df81d6359a6396627da26fb16c30fb568a3e4 (patch)
tree50395353299d082f90bf5879572945729207ed14 /lib/linux.nix
parenta92b587fe0fdd74da7ebc7933ad20263d5b3600e (diff)
Improvements
- using fzf-tmux wherever i can now - some more fzf integration tweaks - added some rofi plugins, idk if they work tho - fixed the polybar sound widget - added autorandr config, it mostly(?) works - added nix-direnv support by default
Diffstat (limited to 'lib/linux.nix')
-rw-r--r--lib/linux.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/lib/linux.nix b/lib/linux.nix
index c234593..6154f00 100644
--- a/lib/linux.nix
+++ b/lib/linux.nix
@@ -239,7 +239,8 @@ in
full-at = 99;
};
"module/volume-bar" = {
- type = "internal/volume";
+ type = "internal/alsa";
+ master-soundcard = "hw:1";
bar-volume-font = 2;
bar-volume-width = 9;
format-volume = "<label-volume><bar-volume>";
@@ -427,6 +428,16 @@ in
rofi = {
enable = true;
+ pass.enable = true;
+ plugins = with pkgs; [
+ rofi-calc
+ rofi-emoji
+ rofi-file-browser
+ rofi-menugen
+ rofi-mpd
+ rofi-pass
+ rofi-systemd
+ ];
};
};