summaryrefslogtreecommitdiff
path: root/lib/packages.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-11-01 12:16:34 -0600
committerBen Sima <ben@bsima.me>2021-11-01 12:16:34 -0600
commit22950ff17da1d197f55f1e73783da9077c2e3cdb (patch)
tree7736a93fb99ebc3103429958ae6dd9cab7950721 /lib/packages.nix
parente71cabacfd3af0e4426d7cfd1edbabf564b8fd4d (diff)
extract programs.{ssh,emacs}
Diffstat (limited to 'lib/packages.nix')
-rw-r--r--lib/packages.nix125
1 files changed, 63 insertions, 62 deletions
diff --git a/lib/packages.nix b/lib/packages.nix
index 41acbef..e73eafc 100644
--- a/lib/packages.nix
+++ b/lib/packages.nix
@@ -1,4 +1,4 @@
-{ pkgs }:
+{ pkgs, ... }:
# All common packages go here. Linux-specific should go in `linux.nix'
@@ -19,64 +19,65 @@ let
cp ./zebra $out/bin
'';
};
-in [
-asciinema
-ag
-amfora
-aspellDicts.en
-bat
-bc
-cabal2nix
-cloc
-cmatrix
-ctags
-dhall
-direnv
-entr
-eternal-terminal
-expect
-fd
-figlet
-file
-font-awesome_5
-gitAndTools.stgit
-git-lfs
-git-revise
-github-cli
-hashcash
-htop
-httpstat
-ispell
-jq
-lsof
-material-icons
-mononoki
-mpc_cli
-ncdu
-ncmpc
-nix-prefetch-scripts
-nixos-generators
-noto-fonts-emoji
-opentimestamps-client
-ormolu
-paperkey
-pass
-perlPackages.GitAutofixup
-pianobar
-pup
-pwgen
-python37Packages.black
-ranger
-ripgrep
-shellcheck
-tmux
-tree
-unrar
-unzip
-urlscan
-vimpager
-w3m
-whois
-zebra
-zip
-]
+in {
+ home.packages = [
+ asciinema
+ ag
+ amfora
+ aspellDicts.en
+ bat
+ bc
+ cabal2nix
+ cloc
+ cmatrix
+ ctags
+ dhall
+ direnv
+ entr
+ eternal-terminal
+ expect
+ fd
+ figlet
+ file
+ font-awesome_5
+ gitAndTools.stgit
+ git-lfs
+ git-revise
+ github-cli
+ hashcash
+ htop
+ httpstat
+ ispell
+ jq
+ lsof
+ material-icons
+ mononoki
+ mpc_cli
+ ncdu
+ ncmpc
+ nix-prefetch-scripts
+ nixos-generators
+ noto-fonts-emoji
+ opentimestamps-client
+ ormolu
+ paperkey
+ pass
+ perlPackages.GitAutofixup
+ pianobar
+ pup
+ pwgen
+ ranger
+ ripgrep
+ shellcheck
+ tmux
+ tree
+ unrar
+ unzip
+ urlscan
+ vimpager
+ w3m
+ whois
+ zebra
+ zip
+ ];
+}