summaryrefslogtreecommitdiff
path: root/lib/theme.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-05-30 15:10:19 -0400
committerBen Sima <ben@bsima.me>2024-05-30 15:10:19 -0400
commitb78a6fa7c96895dfde29cf1c639bc64b3b5a63cc (patch)
treea9b5c2bacf39207d6465a373a4c65780c59d4a0b /lib/theme.nix
parent06f15eba9331db662f2c377051542e3900d228d5 (diff)
oops, lots of updates
- got it working on beryl and my new framework laptop - refactored stuff in the process - added some catppuccin theme stuff
Diffstat (limited to 'lib/theme.nix')
-rw-r--r--lib/theme.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/theme.nix b/lib/theme.nix
new file mode 100644
index 0000000..1020514
--- /dev/null
+++ b/lib/theme.nix
@@ -0,0 +1,24 @@
+{ pkgs, lib }:
+let
+ inherit (import ./const.nix) homedir;
+in rec {
+ theme = lib.removeSuffix "\n" (builtins.readFile "${homedir}/.local/share/xtheme");
+
+ base16-scheme = "atelier-sulphurpool";
+ base16-scheme-filename = lib.strings.concatStrings (lib.strings.splitString "-" base16-scheme);
+ xresourcesFile = "${pkgs.base16}/xresources/base16-${base16-scheme-filename}.${theme}.256.xresources";
+
+
+ colors = { # derived from spacemacs
+ "dark" = {
+ highlight = "#5d4d7a";
+ background = "#292b2e";
+ foreground = "#b2b2b2";
+ };
+ "light" = {
+ highlight = "#67b11d";
+ background = "#f6f1e1";
+ foreground = "#655370";
+ };
+ };
+}