summaryrefslogtreecommitdiff
path: root/lib/urxvt.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-05-30 15:10:19 -0400
committerBen Sima <ben@bsima.me>2024-05-30 15:10:19 -0400
commitb78a6fa7c96895dfde29cf1c639bc64b3b5a63cc (patch)
treea9b5c2bacf39207d6465a373a4c65780c59d4a0b /lib/urxvt.nix
parent06f15eba9331db662f2c377051542e3900d228d5 (diff)
oops, lots of updates
- got it working on beryl and my new framework laptop - refactored stuff in the process - added some catppuccin theme stuff
Diffstat (limited to 'lib/urxvt.nix')
-rw-r--r--lib/urxvt.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/urxvt.nix b/lib/urxvt.nix
new file mode 100644
index 0000000..7fe2351
--- /dev/null
+++ b/lib/urxvt.nix
@@ -0,0 +1,24 @@
+{ ... }:
+let
+ #inherit (import ./const.nix) fontSize;
+ fontSize = 10;
+in {
+ programs.urxvt = let font = name: size: "xft:${name}:size=${toString size}:ant"; in {
+ enable = true;
+ fonts = [
+ (font "Fira Code" fontSize)
+ (font "FiraCodeNerdfont" fontSize)
+ "xft:Noto Emoji"
+ ];
+ #keybindings = {
+ # # why don't any of these work?
+ # "Shift-Control-C" = "eval:selection_to_clipboard";
+ # "Shift-Control-V" = "eval:paste_clipboard";
+ # "Shift-Control-+" = "command:\033]710;${font 12}\007\033]711;${font 12}\007";
+ # "Shift-Control--" = "command:\033]710;${font 8}\007\033]711;${font 8}\007";
+ #};
+ iso14755 = true; # unicode chars
+ #transparent = true;
+ #shading = 10;
+ };
+}