summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <bsima@groq.com>2019-06-11 13:37:25 -0700
committerBen Sima <ben@bsima.me>2019-07-09 15:49:50 -0700
commit0176935d1d53b71555b4809d08b1195fe80c4b2e (patch)
tree97a823a76e3a32bb5663b1a0056ffd84d123bf1c /linux.nix
parentfc1329fc2fa4d94f5881d7079c0190d28b0796ce (diff)
refactor for and setup groq machine
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix134
1 files changed, 128 insertions, 6 deletions
diff --git a/linux.nix b/linux.nix
index 9d26562..7e606bc 100644
--- a/linux.nix
+++ b/linux.nix
@@ -2,6 +2,23 @@
let
homedir = builtins.getEnv "HOME";
+ cmdtree = stdenv.mkDerivation {
+ name = "cmdtree";
+ src = fetchGit {
+ url = "https://git.sr.ht/~jb55/cmdtree";
+ ref = "master";
+ rev = "5606078e8fa02462f0208d9f9cad98c7673812e6";
+ };
+ buildPhase = ''
+ cp ${./cfg.def.h} ./cfg.def.h
+ make
+ '';
+ installPhase = ''
+ mkdir -p $out/bin
+ cp ./cmdtree $out/bin
+ '';
+ buildInputs = [ pkgs.xorg.libX11 pkgs.xorg.libXft ];
+ };
base16-scheme = "spacemacs";
base16 = pkgs.stdenv.mkDerivation {
@@ -35,12 +52,83 @@ let
in
{
imports = [ ./common.nix ./email.nix ];
- home.packages = [
- pkgs.gnupg
- pkgs.pinentry
- pkgs.pavucontrol
- pkgs.keybase-gui
- ];
+ home = {
+ keyboard.options = [ "caps:ctrl_modifier" ];
+ file = {
+ mutt = {
+ text = (builtins.readFile ./muttrc) +
+ (builtins.readFile ./mutt/solarized.muttrc);
+ target = ".muttrc";
+ };
+ mailcap = {
+ source = ./mailcap;
+ target = ".mailcap";
+ };
+ tmux = {
+ source = ./tmux;
+ target = ".tmux.conf";
+ };
+ };
+
+ packages = with pkgs; [
+ gnupg
+ pinentry
+ pavucontrol
+ keybase-gui
+ cmdtree
+ bind
+ exercism
+ tmux
+ gnumake
+ dict
+ gopher
+ w3m
+ yank
+ beets
+ blueman
+ busybox
+ dmenu
+ dolphin
+ feh
+ flameshot
+ hledger
+ hledger-ui
+ hledger-web
+ ledger
+ libnotify
+ minitube
+ mplayer
+ muchsync
+ neomutt
+ obs-studio
+ pandoc
+ qutebrowser
+ tdesktop
+ texlive.combined.scheme-full
+ xorg.xmodmap
+ xournal
+ xterm
+ msmtp
+sqlite
+terminus
+mononoki
+pasystray
+pdftk
+youtube-dl
+zoom-us
+ glibcLocales # rofi locale fix -- https://github.com/rycee/home-manager/issues/354#issuecomment-415914278
+ vlc
+
+ # languages i regularly use
+ clojure
+ ghc
+ guile
+ ocaml
+ python3
+ lispPackages.quicklisp
+ sbcl
+ ];
+ };
fonts.fontconfig.enable = true;
xresources = {
@@ -276,6 +364,40 @@ in
};
programs = {
+ emacs = {
+ enable = true;
+ extraPackages = epkgs: import ./emacs-packages.nix { inherit epkgs; };
+ };
+
+ git = {
+ enable = true;
+ userName = "Ben Sima";
+ userEmail = "ben@bsima.me";
+ ignores = [ "*~" "*.swp" ];
+ package = pkgs.gitAndTools.gitFull;
+ signing = {
+ key = gpgid;
+ signByDefault = true;
+ };
+ aliases = {
+ authors = "shortlog -s -n";
+ };
+ extraConfig = ''
+ [push]
+ default = simple
+
+ [commit]
+ template = ${gitCommitTemplate}
+
+ [sendemail]
+ smtpuser = ben@bsima.me
+ smptserverport = 587
+ smptserver = mail.bsima.me
+ chainreplyto = false
+ composeencoding = UTF-8
+ '';
+ };
+
firefox = {
enable = true;
};