summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-11 09:29:49 -0700
committerBen Sima <ben@bsima.me>2019-04-11 09:29:49 -0700
commit2478c4b2ffc48e25035e5fd0b99751996469c1ce (patch)
treec665c2476c4a8d377f82fe022398f050f974f70c /linux.nix
parenta15f8b5641d2779ccea6b2c80b8a30ddc4c016bd (diff)
activate dunst notifier
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix27
1 files changed, 25 insertions, 2 deletions
diff --git a/linux.nix b/linux.nix
index 23f4b5a..f712844 100644
--- a/linux.nix
+++ b/linux.nix
@@ -118,8 +118,31 @@ in
'';
};
- taffybar = {
- enable = false;
+ dunst = {
+ enable = true;
+ settings = {
+ global = {
+ geometry = "320x5-10+30"; # span entire top bar
+ transparency = 0;
+ frame_color = colors."${theme}".highlight;
+ frame_width = 3; # same as xmonad border
+ separator_color = "frame";
+ font = "Fira Sans";
+ background = colors."${theme}".background;
+ foreground = colors."${theme}".foreground;
+ padding = 10;
+ horizontal_padding = 10;
+ word_wrap = "yes";
+ markup = "full";
+ format = "<b>%s</b>\\n%b\\n";
+ };
+
+ urgency_normal = {
+ background = colors."${theme}".background;
+ foreground = colors."${theme}".foreground;
+ timeout = 10;
+ };
+ };
};
redshift = {