summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-10 21:39:41 -0700
committerBen Sima <ben@bsima.me>2019-04-10 21:39:41 -0700
commit3678c2da69edca53a914f917c818e532f5736453 (patch)
tree3ce17d652c3f69bac1f326ee0aae8aedd14536f0 /linux.nix
parent535faaa791f2cecf0c9f8fba263183e7813be422 (diff)
polybar: add more modules
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix33
1 files changed, 29 insertions, 4 deletions
diff --git a/linux.nix b/linux.nix
index 1000c4f..04c8236 100644
--- a/linux.nix
+++ b/linux.nix
@@ -58,10 +58,10 @@ in
tray-offset-y = 0;
tray-padding = 0;
tray-scale = 1;
- module-margin = 4;
+ module-margin = 1;
modules-left = "ewmh";
modules-center = "date";
- modules-right = "battery";
+ modules-right = [ "ethernet" "wifi" "battery" "volume" "cpu" ];
};
"module/date" = {
type = "internal/date";
@@ -76,17 +76,42 @@ in
adapter = "AC";
full-at = 99;
};
+ "module/volume" = {
+ type = "internal/alsa";
+ interval = 5;
+ label-volume = "vol: %percentage%% ";
+ };
"module/ewmh" = {
type = "internal/xworkspaces";
- pin-workspaces = true;
enable-click = true;
enable-scroll = false;
};
+ "module/ethernet" = {
+ type = "internal/network";
+ interface = "enp1s0";
+ label-connected = "eth: %upspeed:9%↑ %downspeed%↓ ";
+ label-disconnected = "eth down";
+ };
+ "module/wifi" = {
+ type = "internal/network";
+ interface = "wlan1";
+ label-connected = "wifi up: %upspeed% down: %downspeed%";
+ label-disconnected = "wifi down";
+ };
+ "module/cpu" = {
+ type = "internal/cpu";
+ label = "cpu: %percentage%%";
+ };
+ "module/mail" = {
+ # doesn't work, can't find "notmuch", idk why
+ type = "custom/script";
+ exec = "notmuch count tag:inbox and tag:unread";
+ label = "mail: %output%";
+ };
};
script = ''
#!/usr/bin/env sh
systemctl --user daemon-reload
- pasystray &
polybar top &
'';
};