summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-16 21:31:55 -0700
committerBen Sima <ben@bsima.me>2020-04-16 21:31:55 -0700
commit5e16899ecf052a3d6fb91018cf0ac2e78419f687 (patch)
tree2a9cdc5cd25c4bd7c322b60346433ad7e2bf3d2c /linux.nix
parent998df334235a234d75b4545ddfd4e021218faa16 (diff)
Redo email stuff on linux
This will only work on my server... i'll have to refactor it if I want to use it on my laptop too :(
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/linux.nix b/linux.nix
index 7dcef5c..9a24ee6 100644
--- a/linux.nix
+++ b/linux.nix
@@ -2,6 +2,7 @@
let
homedir = builtins.getEnv "HOME";
+ hostname = builtins.getEnv "HOSTNAME";
gitCommitTemplate = ./lib/git-commit-template;
gpgid = "D09299626FA78AF8";
cmdtree = pkgs.stdenv.mkDerivation {
@@ -158,6 +159,12 @@ in
kbfs.enable = true;
keybase.enable = true;
+ mbsync = {
+ enable = true; #if hostname == "lithium" then true else false;
+ frequency = "*:0/15";
+ postExec = "${pkgs.notmuch}/bin/notmuch new";
+ };
+
polybar = {
# https://github.com/0x746866/dots/blob/master/polybar/config
enable = true;
@@ -410,5 +417,10 @@ in
rofi = {
enable = true;
};
+
+ notmuch = {
+ enable = true;
+ hooks.postNew = "${pkgs.afew}/bin/afew -tn && ${pkgs.afew}/bin/afew -t tag:inbox";
+ };
};
}