summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-07-07 15:19:47 -0700
committerBen Sima <ben@bsima.me>2019-07-07 15:19:47 -0700
commit683bcee02bbd51242c15afe57b261ab2aee80dc2 (patch)
tree54220d77db8ee9e01b6c322905fa4556b670f59a /linux.nix
parente392b7c70949620962e280be39e3670ba8b9b4f2 (diff)
more polybar rice
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix97
1 files changed, 72 insertions, 25 deletions
diff --git a/linux.nix b/linux.nix
index 9de8a13..2dcf92b 100644
--- a/linux.nix
+++ b/linux.nix
@@ -72,26 +72,29 @@ in
enable = true;
config = {
"bar/top" = {
+ background = colors."${theme}".background;
font-0 = "FiraSans:size=16";
+ font-1 = "Font Awesome 5:pixelsize=11;1";
+ font-2 = "MaterialIcons:size=10:antialias=false;2";
+ foreground = colors."${theme}".foreground;
+ height = "30";
+ module-margin = 1;
+ modules-center = "date";
+ modules-left = "volume-bar";
+ modules-right = [ "battery" "cpu" "temp" ];
monitor = "\${env:MONITOR:HDMI-1}";
monitor-fallback = "\${env:MONITOR:eDP-1}";
- width = "100%";
- height = "5%";
radius = 0;
- background = colors."${theme}".background;
- foreground = colors."${theme}".foreground;
- tray-position = "right";
+ separator = "|";
+ tray-background = colors."${theme}".background;
tray-detached = false;
tray-maxsize = 16;
- tray-background = colors."${theme}".background;
tray-offset-x = 0;
tray-offset-y = 0;
tray-padding = 0;
+ tray-position = "right";
tray-scale = 1;
- module-margin = 1;
- modules-left = "ewmh";
- modules-center = "date";
- modules-right = [ "ethernet" "wifi" "battery" "volume" "cpu" ];
+ width = "100%";
};
"module/date" = {
type = "internal/date";
@@ -106,15 +109,27 @@ in
adapter = "AC";
full-at = 99;
};
- "module/volume" = {
- type = "internal/alsa";
- interval = 5;
- label-volume = "vol: %percentage%% ";
- };
- "module/ewmh" = {
- type = "internal/xworkspaces";
- enable-click = true;
- enable-scroll = false;
+ "module/volume-bar" = {
+ type = "internal/volume";
+ bar-volume-font = 2;
+ bar-volume-width = 9;
+ format-volume = "<label-volume><bar-volume>";
+ label-volume = " .) ";
+ label-muted = " .) mute";
+ label-volume-foreground = colors.${theme}.foreground;
+ format-muted-foreground = colors.${theme}.foreground;
+ bar-volume-foreground-0 = colors.${theme}.foreground;
+ bar-volume-foreground-1 = colors.${theme}.foreground;
+ bar-volume-foreground-2 = colors.${theme}.foreground;
+ bar-volume-foreground-3 = colors.${theme}.foreground;
+ bar-volume-foreground-4 = colors.${theme}.foreground;
+ bar-volume-foreground-5 = colors.${theme}.foreground;
+ bar-volume-foreground-6 = colors.${theme}.foreground;
+ bar-volume-gradient = true;
+ bar-volume-indicator = "•";
+ bar-volume-fill = "•";
+ bar-volume-empty = "·";
+ bar-volume-empty-foreground = colors.${theme}.foreground;
};
"module/ethernet" = {
type = "internal/network";
@@ -130,13 +145,45 @@ in
};
"module/cpu" = {
type = "internal/cpu";
- label = "cpu: %percentage%%";
+ interval = 3;
+ format-padding = 1;
+ format = "<label> <ramp-coreload>";
+ label = " %percentage:2%%";
+ ramp-coreload-0 = "▂";
+ ramp-coreload-1 = "▃";
+ ramp-coreload-2 = "▄";
+ ramp-coreload-3 = "▅";
+ ramp-coreload-4 = "▆";
+ ramp-coreload-5 = "▇";
+ ramp-coreload-0-foreground = colors.${theme}.foreground;
+ ramp-coreload-1-foreground = colors.${theme}.foreground;
+ ramp-coreload-2-foreground = colors.${theme}.foreground;
+ ramp-coreload-3-foreground = colors.${theme}.foreground;
+ ramp-coreload-4-foreground = colors.${theme}.foreground;
+ ramp-coreload-5-foreground = colors.${theme}.highlight;
};
- "module/mail" = {
- # doesn't work, can't find "notmuch", idk why
- type = "custom/script";
- exec = "notmuch count tag:inbox and tag:unread";
- label = "mail: %output%";
+ "module/temp" = {
+ type = "internal/temperature";
+ interval = 3;
+ thermal-zone = 0;
+ warn-temperature = 70;
+ format = "<ramp> <label>";
+ format-padding = 1;
+ label = "%temperature-c%";
+ ramp-0 = "";
+ ramp-1 = "";
+ ramp-2 = "";
+ ramp-3 = "";
+ ramp-4 = "";
+ ramp-0-foreground = colors.${theme}.foreground;
+ ramp-1-foreground = colors.${theme}.foreground;
+ ramp-2-foreground = colors.${theme}.foreground;
+ ramp-3-foreground = colors.${theme}.foreground;
+ ramp-4-foreground = colors.${theme}.highlight;
+ format-warn = "<label-warn>";
+ label-warn = " %temperature-c%";
+ label-warn-padding = 1;
+ label-warn-foreground = colors.${theme}.highlight;
};
};
script = ''