summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-07-07 15:47:28 -0700
committerBen Sima <ben@bsima.me>2019-07-07 15:47:28 -0700
commit72400bb76677ae44236ae9712d31de4558383675 (patch)
tree6035d17d9e82548d7092c861661ff3fb3bd1103d /linux.nix
parentc05ed3064fc3fabe4691cd35483a1c098a2b7aa6 (diff)
polybar mem module
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/linux.nix b/linux.nix
index 2dcf92b..9d26562 100644
--- a/linux.nix
+++ b/linux.nix
@@ -69,6 +69,7 @@ in
keybase.enable = true;
polybar = {
+ # https://github.com/0x746866/dots/blob/master/polybar/config
enable = true;
config = {
"bar/top" = {
@@ -81,7 +82,7 @@ in
module-margin = 1;
modules-center = "date";
modules-left = "volume-bar";
- modules-right = [ "battery" "cpu" "temp" ];
+ modules-right = [ "battery" "cpu" "mem" "temp" ];
monitor = "\${env:MONITOR:HDMI-1}";
monitor-fallback = "\${env:MONITOR:eDP-1}";
radius = 0;
@@ -185,6 +186,13 @@ in
label-warn-padding = 1;
label-warn-foreground = colors.${theme}.highlight;
};
+ "module/mem" = {
+ type = "internal/memory";
+ interval = 3;
+ format = "<label>";
+ label-padding = 1;
+ label = " %percentage_used%%";
+ };
};
script = ''
#!/usr/bin/env sh