summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-09-04 00:08:42 -0700
committerBen Sima <ben@bsima.me>2019-09-04 00:11:19 -0700
commit81aedbea6a4507e4cfcaf41673518eed94fd5674 (patch)
tree343422a344938d4983777c96604221043f01ff22 /linux.nix
parentf6601841d5c977bf044842a56a5947509f2fe6f4 (diff)
formatting
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix111
1 files changed, 57 insertions, 54 deletions
diff --git a/linux.nix b/linux.nix
index 3d3dbd5..ffdfffa 100644
--- a/linux.nix
+++ b/linux.nix
@@ -53,7 +53,10 @@ let
};
in
{
- imports = [ ./lib/common.nix ./lib/email.nix ];
+ imports = [
+ ./lib/common.nix
+ ./lib/email.nix
+ ];
home = {
keyboard.options = [ "caps:ctrl_modifier" ];
file = {
@@ -70,59 +73,59 @@ in
packages = with pkgs; [
- beets
- bind
- blueman
- cmdtree
- dict
- dmenu
- dolphin
- exercism
- feh
- flameshot
- glibcLocales # rofi locale fix -- https://github.com/rycee/home-manager/issues/354#issuecomment-415914278
- gnumake
- gnupg
- gopher
- hledger
- hledger-ui
- hledger-web
- keybase-gui
- ledger
- libnotify
- minitube
- mononoki
- mplayer
- msmtp
- muchsync
- neomutt
- obs-studio
- pandoc
- pasystray
- pavucontrol
- pdftk
- pinentry
- qutebrowser
- sqlite
- tdesktop
- terminus
- texlive.combined.scheme-full
- vlc
- xorg.xmodmap
- xournal
- xterm
- yank
- youtube-dl
- zathura
+ beets
+ bind
+ blueman
+ cmdtree
+ dict
+ dmenu
+ dolphin
+ exercism
+ feh
+ flameshot
+ glibcLocales # rofi locale fix -- https://github.com/rycee/home-manager/issues/354#issuecomment-415914278
+ gnumake
+ gnupg
+ gopher
+ hledger
+ hledger-ui
+ hledger-web
+ keybase-gui
+ ledger
+ libnotify
+ minitube
+ mononoki
+ mplayer
+ msmtp
+ muchsync
+ neomutt
+ obs-studio
+ pandoc
+ pasystray
+ pavucontrol
+ pdftk
+ pinentry
+ qutebrowser
+ sqlite
+ tdesktop
+ terminus
+ texlive.combined.scheme-full
+ vlc
+ xorg.xmodmap
+ xournal
+ xterm
+ yank
+ youtube-dl
+ zathura
- # languages i regularly use
- clojure
- ghc
- guile
- ocaml
- python3
- lispPackages.quicklisp
- sbcl
+ # languages i regularly use
+ clojure
+ ghc
+ guile
+ ocaml
+ python3
+ lispPackages.quicklisp
+ sbcl
];
};
fonts.fontconfig.enable = true;
@@ -286,7 +289,7 @@ in
dunst = {
enable = true;
settings = {
- global = {
+ global = {
geometry = "320x5-10+30";
transparency = 0;
frame_color = colors."${theme}".highlight;