summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-12 17:23:45 -0800
committerBen Sima <ben@bsima.me>2020-11-12 17:27:06 -0800
commit9c82b37bb66e4063cfd798e4a8e753e870170a0f (patch)
tree2bf13d0de7d04c113d2439fdf15257edebc8d0e0 /linux.nix
parentb27c92c2441c6afc5b1f3486532d0f7484a66b2f (diff)
Remove deprecated syntax
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix26
1 files changed, 11 insertions, 15 deletions
diff --git a/linux.nix b/linux.nix
index edbaf9c..a1b9107 100644
--- a/linux.nix
+++ b/linux.nix
@@ -3,7 +3,6 @@
let
homedir = builtins.getEnv "HOME";
hostname = builtins.getEnv "HOSTNAME";
- gitCommitTemplate = ./lib/git-commit-template;
gpgid = "D09299626FA78AF8";
cmdtree = pkgs.stdenv.mkDerivation {
name = "cmdtree";
@@ -391,20 +390,17 @@ in
aliases = {
authors = "shortlog -s -n";
};
- extraConfig = ''
- [push]
- default = simple
-
- [commit]
- template = ${gitCommitTemplate}
-
- [sendemail]
- smtpuser = ben@bsima.me
- smptserverport = 587
- smptserver = mail.bsima.me
- chainreplyto = false
- composeencoding = UTF-8
- '';
+ extraConfig = {
+ push.default = "simple";
+ commit.template = builtins.readFile ./lib/git-commit-template;
+ sendemail = {
+ smtpuser = "ben@bsima.me";
+ smtpserverport = 587;
+ smtpserver = "mail.bsima.me";
+ chainreplyto = false;
+ composeencoding = "UTF-8";
+ };
+ };
};
emacs = {