summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-07-09 15:48:29 -0700
committerBen Sima <ben@bsima.me>2019-07-09 15:49:50 -0700
commitbf1825677bf32694235c337093b311fa080dded6 (patch)
treedac0c96e9ca5221ab7e5ef3dc48628ee6a24160f /linux.nix
parent25f6583fbb3e964b083769d77eee6030130c3b7a (diff)
fixups from groq patches
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix83
1 files changed, 24 insertions, 59 deletions
diff --git a/linux.nix b/linux.nix
index 7e606bc..4af1267 100644
--- a/linux.nix
+++ b/linux.nix
@@ -2,7 +2,7 @@
let
homedir = builtins.getEnv "HOME";
- cmdtree = stdenv.mkDerivation {
+ cmdtree = pkgs.stdenv.mkDerivation {
name = "cmdtree";
src = fetchGit {
url = "https://git.sr.ht/~jb55/cmdtree";
@@ -64,61 +64,55 @@ in
source = ./mailcap;
target = ".mailcap";
};
- tmux = {
- source = ./tmux;
- target = ".tmux.conf";
- };
};
packages = with pkgs; [
- gnupg
- pinentry
- pavucontrol
- keybase-gui
- cmdtree
- bind
- exercism
- tmux
- gnumake
- dict
- gopher
- w3m
- yank
+
beets
+ bind
blueman
- busybox
+ cmdtree
+ dict
dmenu
dolphin
+ exercism
feh
flameshot
+ glibcLocales # rofi locale fix -- https://github.com/rycee/home-manager/issues/354#issuecomment-415914278
+ gnumake
+ gnupg
+ gopher
hledger
hledger-ui
hledger-web
+ keybase-gui
ledger
libnotify
minitube
+ mononoki
mplayer
+ msmtp
muchsync
neomutt
obs-studio
pandoc
+ pasystray
+ pavucontrol
+ pdftk
+ pinentry
qutebrowser
+ sqlite
tdesktop
+ terminus
texlive.combined.scheme-full
+ vlc
xorg.xmodmap
xournal
xterm
- msmtp
-sqlite
-terminus
-mononoki
-pasystray
-pdftk
-youtube-dl
-zoom-us
- glibcLocales # rofi locale fix -- https://github.com/rycee/home-manager/issues/354#issuecomment-415914278
- vlc
-
+ yank
+ youtube-dl
+ zathura
+
# languages i regularly use
clojure
ghc
@@ -369,35 +363,6 @@ zoom-us
extraPackages = epkgs: import ./emacs-packages.nix { inherit epkgs; };
};
- git = {
- enable = true;
- userName = "Ben Sima";
- userEmail = "ben@bsima.me";
- ignores = [ "*~" "*.swp" ];
- package = pkgs.gitAndTools.gitFull;
- signing = {
- key = gpgid;
- signByDefault = true;
- };
- aliases = {
- authors = "shortlog -s -n";
- };
- extraConfig = ''
- [push]
- default = simple
-
- [commit]
- template = ${gitCommitTemplate}
-
- [sendemail]
- smtpuser = ben@bsima.me
- smptserverport = 587
- smptserver = mail.bsima.me
- chainreplyto = false
- composeencoding = UTF-8
- '';
- };
-
firefox = {
enable = true;
};